configure.ac 2.31 KB
Newer Older
1
AC_PREREQ(2.53)
Zeeshan Ali (Khattak)'s avatar
Zeeshan Ali (Khattak) committed
2
AC_INIT(gupnp, 0.13.1, http://www.gupnp.org/)
3
AM_INIT_AUTOMAKE()
4
AC_CONFIG_SRCDIR(libgupnp/gupnp.h)
5 6 7 8 9 10 11
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE

AC_ISC_POSIX
AC_PROG_CC
AC_STDC_HEADERS
AC_PROG_LIBTOOL
12
AC_FUNC_MMAP
13
AC_SYS_LARGEFILE
14

15 16
PKG_CHECK_MODULES(LIBGUPNP, glib-2.0 >= 2.18 \
                            gobject-2.0 >= 2.18 \
17
                            gmodule-2.0 \
Ross Burton's avatar
Ross Burton committed
18
                            gssdp-1.0 >= 0.7 \
19
                            libsoup-2.4 >= 2.4.1 \
20
                            libxml-2.0 \
21
                            uuid)
22

23 24
PKG_CHECK_MODULES(GTHREAD, gthread-2.0)

25
AC_ARG_WITH([context_manager],
26 27 28
            AS_HELP_STRING(
                        [--with-context-manager=@<:@network-manager/unix@:>@],
                        [Context Manager backend to use]),,
29
            [with_context_manager="unix"])
30 31 32 33 34 35 36

AC_MSG_CHECKING([Context Manager backend to use])
AC_MSG_RESULT([${with_context_manager}])

AM_CONDITIONAL([USE_NETWORK_MANAGER],
               [test "x$with_context_manager" = "xnetwork-manager"])

37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
USE_CONIC=no
if test "x$with_context_manager" = "xunix"; then
        dnl Use libconic if it's available
        PKG_CHECK_MODULES(LIBCONIC, conic >= 0.13,
                          [ USE_CONIC=yes
                            AC_SUBST(LIBCONIC_CFLAGS)
                            AC_SUBST(LIBCONIC_LIBS)
                          ],
                          [ USE_CONIC=no
                            AC_MSG_WARN([conic 0.13 or greater not found.])
                          ])
fi

AM_CONDITIONAL(USE_CONIC, test x$USE_CONIC = xyes)
AC_SUBST(USE_CONIC)

# We need dbus-glib if either NetworkManager or libconic is used
if test "x$with_context_manager" = "xnetwork-manager" -o \
        "x$with_context_manager" = "xunix" -a \
        "x$USE_CONIC" = "xyes"; then
        PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.76)
fi

60 61 62 63 64 65 66 67 68 69 70 71
# glib-genmarshal
GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)

# Debugging
AC_ARG_ENABLE(debug,
	[  --enable-debug          enable debugging],,
        enable_debug=no)
if test "x$enable_debug" = "xyes"; then
        CFLAGS="$CFLAGS -g -Wall -Werror"
fi

72
# Gtk-doc
73 74 75 76 77
GTK_DOC_CHECK([1.0])

AC_OUTPUT([
Makefile
libgupnp/Makefile
78
examples/Makefile
79
tools/Makefile
80 81
tests/Makefile
doc/Makefile
82
doc/version.xml
83
gupnp-1.0.pc
84
gupnp-1.0-uninstalled.pc
85
])