Commit 27e2dbec authored by Jens Georg's avatar Jens Georg
Browse files

Force HTTP version 1.1 on SOAP requests

https://bugzilla.gnome.org/show_bug.cgi?id=702555
parent ee096448
......@@ -929,6 +929,14 @@ control_server_handler (SoupServer *server,
return;
}
/* DLNA 7.2.5.6: Always use HTTP 1.1 */
if (soup_message_get_http_version (msg) == SOUP_HTTP_1_0) {
soup_message_set_http_version (msg, SOUP_HTTP_1_1);
soup_message_headers_append (msg->response_headers,
"Connection",
"close");
}
context = gupnp_service_info_get_context (GUPNP_SERVICE_INFO (service));
/* Get action name */
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment