Commit 922cfba1 authored by Brendan Long's avatar Brendan Long

Add Fedora build documentation and switch to libgee-0.8.

parent cc05b923
## Dependencies
On Ubuntu 14.04:
### Ubuntu 14.04
sudo apt-get install git valac libgupnp-dev libgee-dev libjson-glib-dev
sudo apt-get install git valac libgupnp-dev libgee-0.8-dev libjson-glib-dev
# tup build tool
# see: http://gittup.org/tup/
......@@ -10,6 +10,18 @@ On Ubuntu 14.04:
sudo apt-get update
sudo apt-get install tup
### Fedora 20
sudo yum install fuse-devel gupnp-devel libgee-devel vala
# setup Tup
git clone git://github.com/gittup/tup.git
cd tup
./bootstrap.sh
sudo ln -s $PWD/tup /usr/local/bin/tup
cd ..
## Getting Source
git clone https://github.com/cablelabs/gupnp-rui-server.git
......
export PKG_CONFIG_PATH
LD_FLAGS += \$(pkg-config --libs gupnp-1.0 gssdp-1.0 gobject-2.0 libxml-2.0 gee-1.0 json-glib-1.0) -g
VALA_FLAGS += --pkg=gupnp-1.0 --pkg=gee-1.0 --pkg=gio-2.0 --pkg=posix --pkg=json-glib-1.0 -X -w -g
LD_FLAGS += \$(pkg-config --libs gupnp-1.0 gssdp-1.0 gobject-2.0 libxml-2.0 gee-0.8 json-glib-1.0) -g
VALA_FLAGS += --vapidir=$(TUP_CWD)/vapi --pkg=gupnp-1.0 --pkg=gee-0.8 --pkg=gio-2.0 --pkg=posix --pkg=json-glib-1.0 -X -w -g
.gitignore
......
gssdp-1.0
libsoup-2.4
libxml-2.0
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment