Commit d841074f authored by Scott Deboy's avatar Scott Deboy

Update README.md

parent 0c4917f9
......@@ -13,7 +13,7 @@ the `--no-deps` argument.
## Easy Mode
If you don't care how this works and just want a copy of GStreamer from git,
If you don't care how this works and just want a copy of GStreamer from git with ruih/master branches checked out,
run this:
mkdir -p ~/bin ~/gst
......@@ -36,7 +36,7 @@ If you want to update your repos, do:
git pull # In case this repo has changed
./build.sh --reconfigure --no-deps
You will now have the main GStreamer repos checked out in ~/gst/git. The
You will now have the main GStreamer repos ruih/master branches checked out in ~/gst/git. The
script will do rebase merges, and will leave the repos on whatever branch
you set them to, so feel free to switch branches or change the "origin".
......@@ -60,6 +60,7 @@ First, look at the usage information from `./build.sh -h`:
> --no-deps Don't install dependencies before building.
> --reconfigure Force a reconfigure, even if a Makefile already exists.
> --upstream Clone from upstream where possible, instead of our repos (you probably don't want to do this).
> --introspection Enable introspection
In general, you will want to run with the default arguments, but `--no-update`
can be useful if you just want to build everything, but don't want it to switch
......@@ -69,6 +70,8 @@ way to check if dependencies are installed is to attempt to install them).
`--upstream` exists because it's convenient in certain cases, but most likely
you shouldn't use it.
If you don't specify --no-update and also don't specify a --branch argument, your current branches will be switched over to ruih/master.
## Setup
Make sure you check this repo out as ~/gst/$name (~/gst/git for example).
......@@ -106,3 +109,5 @@ commands with gst-git. For example, building and running WebKit:
gst-git Tools/Scripts/build-webkit --qt --video-track
gst-git Tools/Scripts/run-launcher --qt
Also note that when using the gst-uninstalled environment, libraries dependent on gstreamer libraries will include incorrect dependency_libs entries in the installed .la files. Removing the installed .la file or updating the paths in dependency_libs should resolve any link-time issues.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment