Commit 0952f110 authored by lorianderson's avatar lorianderson

Merge pull request #17 from cablelabs/dont-install-nvidia-drivers

Don't ever install nvidia drivers in the build-dep step.
parents d733ad8a 8e34056a
......@@ -138,23 +138,21 @@ if $INSTALL_DEPS ; then
fi
done
echo "Installing build dependencies for$packages"
echo 'Run with --no-deps to skip this step (you need to run this step at least once!)'
if [ "$OS" == "Ubuntu" ]; then
sudo apt-get -y build-dep $packages
# Work around an issue where Ubuntu 13.04 and 13.10 try to install the
# nVidia drivers for OpenCV
depends=$(apt-get -s build-dep $packages | grep Inst | grep -v nvidia | grep -v opencv | cut -d ' ' -f 2 | paste -s -d ' ')
if [[ -n "$depends" ]] ; then
echo "Installing build dependencies for$packages"
sudo apt-get -y install "$depends"
fi
elif [ "$OS" == "Fedora" ]; then
echo "Installing build dependencies for$packages"
echo 'Run with --no-deps to skip this step (you need to run this step at least once!)'
sudo yum-builddep -y -q $packages
fi
# For Kate subtitles
if [[ "$packages" == *plugins-bad* ]] ; then
echo "Installing libkate headers for gst-plugins-bad"
if [ "$OS" == "Ubuntu" ] ; then
sudo apt-get -y install libkate-dev
elif [ "$OS" == "Fedora" ] ; then
sudo yum -y -q install libkate-devel
fi
fi
fi
# Get the name of this gst checkout -- git for ~/gst/git
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment