[GTK] Remove support for compiling with GStreamer 0.10

https://bugs.webkit.org/show_bug.cgi?id=109593

Patch by Martin Robinson <mrobinson@igalia.com> on 2013-02-13
Reviewed by Philippe Normand.

Remove support for building WebKitGTK+ with GStreamer 0.10. We
can simplify things greatly because we don't have to worry any
longer about selecting one GStreamer API set.

* Source/autotools/FindDependencies.m4:
* Source/autotools/ReadCommandLineArguments.m4:
* Source/autotools/SetupAutoconfHeader.m4:
* Source/autotools/Versions.m4:

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@142756 268f45cc-cd09-0410-ab3c-d52691b4dbfc
parent 9f89d496
2013-02-13 Martin Robinson <mrobinson@igalia.com>
[GTK] Remove support for compiling with GStreamer 0.10
https://bugs.webkit.org/show_bug.cgi?id=109593
Reviewed by Philippe Normand.
Remove support for building WebKitGTK+ with GStreamer 0.10. We
can simplify things greatly because we don't have to worry any
longer about selecting one GStreamer API set.
* Source/autotools/FindDependencies.m4:
* Source/autotools/ReadCommandLineArguments.m4:
* Source/autotools/SetupAutoconfHeader.m4:
* Source/autotools/Versions.m4:
2013-02-12 Martin Robinson <mrobinson@igalia.com> 2013-02-12 Martin Robinson <mrobinson@igalia.com>
[GTK] Remove the GLib unicode backend [GTK] Remove the GLib unicode backend
......
...@@ -313,34 +313,6 @@ if test "$enable_svg_fonts" = "yes" && test "$enable_svg" = "no"; then ...@@ -313,34 +313,6 @@ if test "$enable_svg_fonts" = "yes" && test "$enable_svg" = "no"; then
enable_svg=yes enable_svg=yes
fi fi
if test "$enable_video" = "yes" || test "$enable_web_audio" = "yes"; then
if test "$with_gstreamer" = "auto"; then
gstreamer_modules="gstreamer-1.0 >= gstreamer_1_0_required_version gstreamer-app-1.0 gstreamer-audio-1.0
gstreamer-fft-1.0 gstreamer-base-1.0 gstreamer-pbutils-1.0
gstreamer-plugins-base-1.0 >= gstreamer_1_0_plugins_base_required_version gstreamer-video-1.0";
PKG_CHECK_MODULES([GSTREAMER_1_0], [$gstreamer_modules], [with_gstreamer=1.0], [with_gstreamer=0.10])
AC_MSG_NOTICE([Selected GStreamer $with_gstreamer])
fi
else
if test "$with_gstreamer" != "auto"; then
AC_MSG_WARN([You have specified GStreamer $with_gstreamer version but it will not be used
because neither HTML5 Video nor Web Audio are enabled])
fi
fi
case "$with_gstreamer" in
0.10) GSTREAMER_REQUIRED_VERSION=gstreamer_0_10_required_version
GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION=gstreamer_0_10_plugins_base_required_version
GST_API_VERSION=0.10
;;
1.0) GSTREAMER_REQUIRED_VERSION=gstreamer_1_0_required_version
GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION=gstreamer_1_0_plugins_base_required_version
GST_API_VERSION=1.0
;;
esac
AC_SUBST([GST_API_VERSION])
if test "$enable_opcode_stats" = "yes"; then if test "$enable_opcode_stats" = "yes"; then
if test "$enable_jit" = "yes"; then if test "$enable_jit" = "yes"; then
AC_MSG_ERROR([JIT must be disabled for Opcode stats to work.]) AC_MSG_ERROR([JIT must be disabled for Opcode stats to work.])
...@@ -438,16 +410,16 @@ if test "$os_win32" = "no"; then ...@@ -438,16 +410,16 @@ if test "$os_win32" = "no"; then
AC_SUBST([XRENDER_LIBS]) AC_SUBST([XRENDER_LIBS])
fi fi
# Check if Gstreamer is available.
if test "$enable_video" = "yes" || test "$enable_web_audio" = "yes"; then if test "$enable_video" = "yes" || test "$enable_web_audio" = "yes"; then
gstreamer_modules="gstreamer-$GST_API_VERSION >= $GSTREAMER_REQUIRED_VERSION gstreamer-app-$GST_API_VERSION PKG_CHECK_MODULES([GSTREAMER], [
gstreamer-audio-$GST_API_VERSION gstreamer-fft-$GST_API_VERSION gstreamer-base-$GST_API_VERSION gstreamer-1.0 >= gstreamer_required_version
gstreamer-pbutils-$GST_API_VERSION gstreamer-plugins-base-$GST_API_VERSION >= $GSTREAMER_PLUGINS_BASE_REQUIRED_VERSION gstreamer-plugins-base-1.0 >= gstreamer_plugins_base_required_version
gstreamer-video-$GST_API_VERSION"; gstreamer-app-1.0
if test "$GST_API_VERSION" != "1.0"; then gstreamer-audio-1.0,
gstreamer_modules="$gstreamer_modules gstreamer-interfaces-$GST_API_VERSION"; gstreamer-fft-1.0,
fi gstreamer-base-1.0,
PKG_CHECK_MODULES([GSTREAMER], [$gstreamer_modules], [have_gstreamer=yes]) gstreamer-pbutils-1.0,
gstreamer-video-1.0])
AC_SUBST([GSTREAMER_CFLAGS]) AC_SUBST([GSTREAMER_CFLAGS])
AC_SUBST([GSTREAMER_LIBS]) AC_SUBST([GSTREAMER_LIBS])
fi fi
......
...@@ -168,18 +168,6 @@ AC_ARG_ENABLE(debug_symbols, ...@@ -168,18 +168,6 @@ AC_ARG_ENABLE(debug_symbols,
]) ])
AC_MSG_RESULT([$enable_debug_symbols]) AC_MSG_RESULT([$enable_debug_symbols])
AC_MSG_CHECKING([the GStreamer version to use])
AC_ARG_WITH([gstreamer],
AS_HELP_STRING([--with-gstreamer=1.0|0.10|auto], [the GStreamer version to use (default: auto, tries 1.0 first, 0.10 is fallback)]),
[
case "$with_gstreamer" in
0.10|1.0|auto) ;;
*) AC_MSG_ERROR([invalid GStreamer version specified]) ;;
esac
],
[with_gstreamer=auto])
AC_MSG_RESULT([$with_gstreamer])
AC_MSG_CHECKING([which GPU acceleration backend to use]) AC_MSG_CHECKING([which GPU acceleration backend to use])
AC_ARG_WITH(acceleration_backend, AC_ARG_WITH(acceleration_backend,
AC_HELP_STRING([--with-acceleration-backend=@<:@opengl/clutter/none@:>@], AC_HELP_STRING([--with-acceleration-backend=@<:@opengl/clutter/none@:>@],
......
...@@ -72,9 +72,7 @@ if test "$have_gstreamer" = "yes"; then ...@@ -72,9 +72,7 @@ if test "$have_gstreamer" = "yes"; then
fi fi
fi fi
if test "$GST_API_VERSION" = "1.0"; then AC_DEFINE([GST_API_VERSION_1], [1], [Using GStreamer 1.0])
AC_DEFINE([GST_API_VERSION_1], [1], [Using GStreamer 1.0])
fi
if test "$enable_web_audio" = "yes"; then if test "$enable_web_audio" = "yes"; then
AC_DEFINE([WTF_USE_WEBAUDIO_GSTREAMER], [1], [1]) AC_DEFINE([WTF_USE_WEBAUDIO_GSTREAMER], [1], [1])
......
...@@ -28,9 +28,7 @@ m4_define([libsoup_required_version], [2.40.0]) ...@@ -28,9 +28,7 @@ m4_define([libsoup_required_version], [2.40.0])
m4_define([libxml_required_version], [2.6]) m4_define([libxml_required_version], [2.6])
m4_define([pango_required_version], [1.21.0]) m4_define([pango_required_version], [1.21.0])
m4_define([gstreamer_0_10_required_version], [0.10]) m4_define([gstreamer_required_version], [1.0.3])
m4_define([gstreamer_0_10_plugins_base_required_version], [0.10.30]) m4_define([gstreamer_plugins_base_required_version], [1.0.3])
m4_define([gstreamer_1_0_required_version], [1.0.3])
m4_define([gstreamer_1_0_plugins_base_required_version], [1.0.3])
m4_define([gobject_introspection_required], [0.9.5]) m4_define([gobject_introspection_required], [0.9.5])
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment