Commit 5c9d16ee authored by carlosgc@webkit.org's avatar carlosgc@webkit.org

[GTK] Remove compile warnings about GTK+ API deprecated after 3.6

https://bugs.webkit.org/show_bug.cgi?id=118237

Reviewed by Philippe Normand.

We depend on GTK+3.6 so we are not interested in compile warnings
about deprecated API after 3.6

* Source/autotools/SetupAutoconfHeader.m4: Define
GDK_VERSION_MIN_REQUIRED in config.h.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@152712 268f45cc-cd09-0410-ab3c-d52691b4dbfc
parent 6497a327
2013-07-16 Carlos Garcia Campos <cgarcia@igalia.com>
[GTK] Remove compile warnings about GTK+ API deprecated after 3.6
https://bugs.webkit.org/show_bug.cgi?id=118237
Reviewed by Philippe Normand.
We depend on GTK+3.6 so we are not interested in compile warnings
about deprecated API after 3.6
* Source/autotools/SetupAutoconfHeader.m4: Define
GDK_VERSION_MIN_REQUIRED in config.h.
2013-07-09 Carlos Garcia Campos <cgarcia@igalia.com>
Unreviewed. Update NEWS and Versions.m4 for 2.1.3 release.
......
......@@ -21,6 +21,8 @@ fi
if test "$GTK_API_VERSION" = "2.0"; then
AC_DEFINE([GTK_API_VERSION_2], [1], [ ])
else
AC_DEFINE([GDK_VERSION_MIN_REQUIRED], [GDK_VERSION_3_6], [Minimum GTK/GDK version required])
fi
if test "$enable_webkit2" = "yes"; then
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment