Commit 55a22ffc authored by zandobersek@gmail.com's avatar zandobersek@gmail.com

Unreviewed. Attempting to fix webkitpy tests after r161512.

* Scripts/webkitpy/port/gtk.py:
(GtkPort.__init__): Construct LeakDetectorValgrin only if leak detection is enabled.


git-svn-id: http://svn.webkit.org/repository/webkit/trunk@161517 268f45cc-cd09-0410-ab3c-d52691b4dbfc
parent 0237cbb5
2014-01-08 Zan Dobersek <zdobersek@igalia.com>
Unreviewed. Attempting to fix webkitpy tests after r161512.
* Scripts/webkitpy/port/gtk.py:
(GtkPort.__init__): Construct LeakDetectorValgrin only if leak detection is enabled.
2014-01-08 Brian Holt <brian.holt@samsung.com>
[GTK] Parse Valgrind xml leak files
......
......@@ -47,9 +47,9 @@ class GtkPort(Port):
def __init__(self, *args, **kwargs):
super(GtkPort, self).__init__(*args, **kwargs)
self._pulseaudio_sanitizer = PulseAudioSanitizer()
self._leakdetector = LeakDetectorValgrind(self._filesystem, self.results_directory())
if self.get_option("leaks"):
self._leakdetector = LeakDetectorValgrind(self._filesystem, self.results_directory())
if not self.get_option("wrapper"):
raise ValueError('use --wrapper=\"valgrind\" for memory leak detection on GTK')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment