Commit 22b47863 authored by csaavedra@igalia.com's avatar csaavedra@igalia.com

Unreviewed build fix.

.:

* Source/autotools/FindDependencies.m4:
* Source/autotools/Versions.m4:
* Source/cmake/FindHarfBuzz.cmake:

Bump gtk and efl dependencies on harfbuzz
to 0.9.7. See bug 110145.

Tools:

* efl/jhbuild.modules:
* gtk/jhbuild.modules:

Bump harfbuzz module to 0.9.7. See related bug 110145.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@143345 268f45cc-cd09-0410-ab3c-d52691b4dbfc
parent d633162a
2013-02-19 Claudio Saavedra <csaavedra@igalia.com>
Unreviewed build fix.
* Source/autotools/FindDependencies.m4:
* Source/autotools/Versions.m4:
* Source/cmake/FindHarfBuzz.cmake:
Bump gtk and efl dependencies on harfbuzz
to 0.9.7. See bug 110145.
2013-02-19 Changhun Kang <temoochin@company100.net>
Only depend on xrender if x11 is being used
......
......@@ -366,10 +366,10 @@ AC_SUBST([LIBSECRET_LIBS])
# Check if FreeType/FontConfig are available.
if test "$with_target" = "directfb"; then
PKG_CHECK_MODULES([FREETYPE],
[fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz])
[fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
else
PKG_CHECK_MODULES([FREETYPE],
[cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz])
[cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
fi
AC_SUBST([FREETYPE_CFLAGS])
AC_SUBST([FREETYPE_LIBS])
......
......@@ -24,6 +24,7 @@ m4_define([cairo_required_version], [1.10])
m4_define([fontconfig_required_version], [2.4])
m4_define([freetype2_required_version], [9.0])
m4_define([glib_required_version], [2.32.0])
m4_define([harfbuzz_required_version], [0.9.7])
m4_define([libsoup_required_version], [2.40.0])
m4_define([libxml_required_version], [2.6])
m4_define([pango_required_version], [1.21.0])
......
......@@ -32,7 +32,7 @@
include(FindPkgConfig)
pkg_check_modules(PC_HARFBUZZ harfbuzz>=0.9.0)
pkg_check_modules(PC_HARFBUZZ harfbuzz>=0.9.7)
find_path(HARFBUZZ_INCLUDE_DIRS NAMES hb.h
HINTS ${PC_HARFBUZZ_INCLUDE_DIRS} ${PC_HARFBUZZ_INCLUDEDIR}
......
2013-02-19 Claudio Saavedra <csaavedra@igalia.com>
Unreviewed build fix.
* efl/jhbuild.modules:
* gtk/jhbuild.modules:
Bump harfbuzz module to 0.9.7. See related bug 110145.
2013-02-19 Simon Hausmann <simon.hausmann@digia.com>
[Qt] Skip the build with a warning if certain tools cannot be found in the PATH
......@@ -161,11 +161,11 @@
</autotools>
<autotools id="harfbuzz" autogen-sh="configure">
<branch module="software/harfbuzz/release/harfbuzz-0.9.6.tar.bz2" version="0.9.6"
checkoutdir="harfbuzz-0.9.6"
<branch module="software/harfbuzz/release/harfbuzz-0.9.7.tar.bz2" version="0.9.7"
checkoutdir="harfbuzz-0.9.7"
repo="freedesktop.org"
hash="sha256:394a849d6061993018754b0cc04110891ad215e3df3f6953b75dcc55a11f9d9b"
md5sum="f3a100a0512c185b211a0deb4790c34c">
hash="sha256:bd2999859f8828461fedae23e4af52d926ac32a73245f03ae2d2065205e9cf25"
md5sum="db5382728a912352633d3be2e2a1d988">
<patch file="harfbuzz-icu-detection-fix.patch" strip="1" />
</branch>
</autotools>
......
......@@ -92,11 +92,11 @@
</tarball>
<autotools id="harfbuzz" autogen-sh="configure">
<branch module="software/harfbuzz/release/harfbuzz-0.9.6.tar.bz2" version="0.9.6"
checkoutdir="harfbuzz-0.9.6"
<branch module="software/harfbuzz/release/harfbuzz-0.9.7.tar.bz2" version="0.9.7"
checkoutdir="harfbuzz-0.9.7"
repo="freedesktop.org"
hash="sha256:394a849d6061993018754b0cc04110891ad215e3df3f6953b75dcc55a11f9d9b"
md5sum="f3a100a0512c185b211a0deb4790c34c">
hash="sha256:bd2999859f8828461fedae23e4af52d926ac32a73245f03ae2d2065205e9cf25"
md5sum="db5382728a912352633d3be2e2a1d988">
<patch file="harfbuzz-icu-detection-fix.patch" strip="1" />
</branch>
</autotools>
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment