Commit 13bb4476 authored by dpranke@chromium.org's avatar dpranke@chromium.org

run-webkit-tests needs to propagate --chromium

https://bugs.webkit.org/show_bug.cgi?id=76870

Reviewed by Eric Seidel.

run-webkit-tests removes '--chromium' argument from @ARGV when
determining which port to run, which means that that doesn't
propagate to new-run-webkit-tests. That's bad (and is handled
for the other ports by re-adding the flag, but apparently we're
just now noticing for Chromium).

* Scripts/run-webkit-tests:

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@105673 268f45cc-cd09-0410-ab3c-d52691b4dbfc
parent f37684e3
2012-01-23 Dirk Pranke <dpranke@chromium.org>
run-webkit-tests needs to propagate --chromium
https://bugs.webkit.org/show_bug.cgi?id=76870
Reviewed by Eric Seidel.
run-webkit-tests removes '--chromium' argument from @ARGV when
determining which port to run, which means that that doesn't
propagate to new-run-webkit-tests. That's bad (and is handled
for the other ports by re-adding the flag, but apparently we're
just now noticing for Chromium).
* Scripts/run-webkit-tests:
2012-01-23 Brian Weinstein <bweinstein@apple.com>
More build fixing after r105646.
......@@ -110,6 +110,8 @@ if (isQt()) {
push(@ARGV, "--gtk");
} elsif (isEfl()) {
push(@ARGV, "--efl");
} elsif (isChromium()) {
push(@ARGV, "--chromium")
}
my $harnessPath = File::Spec->catfile(relativeScriptsDir(), $harnessName);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment